标签:c++ cpp 编程 数据 acm
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
经典的搜索,然而不看解析我还是不会写,以下为自己领悟
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
char c[30][30];
int m,n;
int dfs(int a,int b) //深度搜索
{
if(c[a][b]=='#'||a>=m||b>=n||a<0||b<0) //遇到障碍或边界时退出,此时没有通路,因此返回的道路条数是0
return 0;
else
{
c[a][b]='#'; //可以继续走时,把走过的地方设置成障碍,防止再走一遍
return 1+dfs(a-1,b)+dfs(a+1,b)+dfs(a,b-1)+dfs(a,b+1); //这条路可以走,所以要先+1,然后从四个方向再继续走
}
}
int main()
{
int i,j,a,b,g;
while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
{
for(i=0; i<m; ++i)
for(j=0; j<n; ++j)
{
cin>>c[i][j];
if(c[i][j]=='@')
{
a=i;
b=j;
}
}
g=dfs(a,b);
printf("%d\n",g);
}
return 0;
}
一些项目——深度搜索
标签:c++ cpp 编程 数据 acm
原文地址:http://blog.csdn.net/blue_skyrim/article/details/46672149