码迷,mamicode.com
首页 > 其他好文 > 详细

三角形问题

时间:2015-06-29 00:14:41      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

问题:You are given the side lengths of a triangle, determine is it an acute triangle, right triangle or obtuse triangle.
 
Input
The first line contains an integer T indicating the number of test cases.
For each test case, there is a single line contains three integer A, B and C indicating the side lengths of the triangle. (You can assume it is a valid triangle)

Technical Specification
1. 1 <= T <= 50
2. 1 <= A,B,C <= 100
 
Output
For each test case, output the case number first, then output "Acute triangle", "Right triangle" or "Obtuse triangle".
 
Sample Input
3
2 2 2
4 8 5
3 4 5

Sample Output
Case 1: Acute triangle
Case 2: Obtuse triangle
Case 3: Right triangle

 

回答:

#include<iostream>
using namespace std;

int main()
{
    int n, p=1;
    scanf("%d", &n);
    while(n--)
    {
        int a, b, c;
        scanf("%d%d%d", &a, &b, &c);
        int t;
        if(a > b)
        {
            t=a;
            a=b;
            b=t;
        }
        if(b > c)
        {
            t=b;
            b=c;
            c=t;
        }
        if(a > b)
        {
            t=a;
            a=b;
            b=t;
        }
        printf("Case %d: ", p++);
        if(a*a+b*b == c*c)
            printf("Right triangle\n");
        else if(a*a+b*b > c*c)
            printf("Acute triangle\n");
        else
            printf("Obtuse triangle\n");
    }
    return 0;
}

三角形问题

标签:

原文地址:http://www.cnblogs.com/benchao/p/4606292.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!