码迷,mamicode.com
首页 > 其他好文 > 详细

第十六周oj刷题——Problem J: 填空题:静态成员---计算学生个数

时间:2015-06-29 20:27:11      阅读:88      评论:0      收藏:0      [点我收藏+]

标签:c++   class   iostream      对象   

Description

学生类声明已经给出,在主程序中根据输入信息输出实际建立的学生对象个数,以及所有学生对象的成绩总和。

Input

学生个数

对应学生个数的学生信息(姓名    年龄    成绩)

Output

学生个数

所有学生的成绩之和

Sample Input

3
guo  34  98
zhang    56  60
li   23   87

Sample Output

the count of student objects=3
/* All rights reserved.
 * 文件名称:test.cpp
 * 作者:陈丹妮
 * 完成日期:2015年 6 月 27 日
 * 版 本 号:v1.0
 */
#include <iostream>
#include <string>
using namespace std;
class student
{
private:
    string name;  //学生姓名
    int age;      //学生年龄
    int score;    //学生成绩
    static int count; //记录学生对象个数
    static int sum;  //记录所有学生的总成绩
public:
    student(string n,int a,int s);  //构造函数
    static int get_count();  //静态成员函数,获取count的值
    static int get_sum();   //静态成员函数,获取sum的值
};


int student::count=0;
int student::sum=0;
student::student(string n,int a,int s)
{
    name=n;
    age=a;
    score=s;
    count++;
    sum+=s;
}
int student::get_count()
{
   return count;
}
int student::get_sum()
{
    return sum;
}

int  main( )
{
    string name;
    int age;
    int score;
    int n;
    cin>>n;  //输入学生对象个数
    while(n--)
    {
        cin>>name>>age>>score;
        new student(name,age,score);
    }
    cout<<"the count of student objects=";
    cout<<student::get_count()<<endl;
    cout<<"the sum of all students score=";
    cout<<student::get_sum()<<endl;
    return 0;
}
技术分享
 
学习心得:静态数据成员不难,挺容易的,继续加油努力吧!!
 

版权声明:本文为博主原创文章,未经博主允许不得转载。

第十六周oj刷题——Problem J: 填空题:静态成员---计算学生个数

标签:c++   class   iostream      对象   

原文地址:http://blog.csdn.net/nufangdongde/article/details/46684751

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!