码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2824 The Euler function(欧拉函数个数)

时间:2014-07-03 17:42:32      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:欧拉函数

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2824

欧拉函数性质:

1:(百科):http://baike.baidu.com/link?url=r-yneKCCyS9N6bhbQCqiZX0V2OCYq9r7iHSzHTSs03H7qRvu1OfUzlOxfVEs2PmR

2:http://www.cppblog.com/doer-xee/archive/2009/12/01/102353.html


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 
Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 
Output
Output the result of (a)+ (a+1)+....+ (b)
 
Sample Input
3 100
 
Sample Output
3042
 
Source

题意:求a到b中每个数的欧拉函数的总和!


代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
#define N 3000001

__int64 phi[N];

void init()
{
    int i, j;
    for(i = 1; i < N; i++)
        phi[i] = i;

    for(i = 2; i < N; i++)
        if(i == phi[i]) //此时i为素数
            for(j = i; j < N; j += i)  //j累加i
                phi[j] = (phi[j] / i) * (i - 1); //j有因子i,而且i是素数,正是欧拉函数
}

int main()
{
    init();
    int a, b;
    while(scanf("%d%d", &a, &b) != EOF)
    {
        __int64 ans = 0;
        for(int i = a; i <= b; i++)
            ans += phi[i];
        printf("%I64d\n", ans);
    }
    return 0;
}


hdu2824 The Euler function(欧拉函数个数),布布扣,bubuko.com

hdu2824 The Euler function(欧拉函数个数)

标签:欧拉函数

原文地址:http://blog.csdn.net/u012860063/article/details/36426357

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!