标签:
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 33670 | Accepted: 14713 |
Description
Input
Output
Sample Input
bwwb bbwb bwwb bwww
Sample Output
4
Source
解析
真是醉了,双重dfs,如果对dfs不是很了解的同学就放弃这道题吧,想了4个小时才想通,脑细胞都快没了,
其实就是step从0枚举到16,之后dfs结构中主要是对每一种可能进行位移式的枚举,一部一部向后推得枚举
附代码
ps:其实本人代码与网上的代码差不多,
本人也是参考网上代码才解决的这道问题
如过有谁不懂可以Q我,1097944404
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
int map[5][5],step,flag;
int judge(){
for(int i=0;i<4;i++){
for(int j=0;j<4;j++){
if(map[i][j]!=map[0][0])
return 0;
}
}
return 1;
}
void update(int x,int y){
map[x][y]^=1;
if(x>0)
map[x-1][y]^=1;
if(x<3)
map[x+1][y]^=1;
if(y>0)
map[x][y-1]^=1;
if(y<3)
map[x][y+1]^=1;
}
void dfs(int x,int y,int step1){
if(step1==step){
flag=judge();
return ;
}
if(flag||x==4)
return;
update(x,y);
if(y<3)
dfs(x,y+1,step1+1);
else
dfs(x+1,0,step1+1);
update(x,y);
if(y<3)
dfs(x,y+1,step1);
else
dfs(x+1,0,step1);
}
int main(){
char z;
for(int i=0;i<4;i++){
for(int j=0;j<4;j++){
scanf("%c",&z);
if(z==‘b‘)
map[i][j]=0;
else
map[i][j]=1;
}
getchar();
}
flag=0;
for( step=0;step<=16;step++){
dfs(0,0,0);
if(flag)
break;
}
if(flag)
printf("%d\n",step);
else
printf("Impossible\n");
return 0;
}
标签:
原文地址:http://www.cnblogs.com/13224ACMer/p/4611558.html