码迷,mamicode.com
首页 > 其他好文 > 详细

poj1753枚举

时间:2015-06-30 21:53:52      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33670   Accepted: 14713

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

技术分享Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

 

 

 

 

 

解析

真是醉了,双重dfs,如果对dfs不是很了解的同学就放弃这道题吧,想了4个小时才想通,脑细胞都快没了,

其实就是step从0枚举到16,之后dfs结构中主要是对每一种可能进行位移式的枚举,一部一部向后推得枚举

附代码

ps:其实本人代码与网上的代码差不多,

本人也是参考网上代码才解决的这道问题

如过有谁不懂可以Q我,1097944404

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
int map[5][5],step,flag;
int judge(){
     for(int i=0;i<4;i++){
        for(int j=0;j<4;j++){
             if(map[i][j]!=map[0][0])
                return 0;
        }
     }
     return 1;
}
void update(int x,int y){
    map[x][y]^=1;
      if(x>0)
          map[x-1][y]^=1;
      if(x<3)
         map[x+1][y]^=1;
         if(y>0)
         map[x][y-1]^=1;
         if(y<3)
         map[x][y+1]^=1;
}

void dfs(int x,int y,int step1){
    if(step1==step){
         flag=judge();
         return ;
    }
    if(flag||x==4)
         return;
       update(x,y);
       if(y<3)
         dfs(x,y+1,step1+1);
         else
         dfs(x+1,0,step1+1);
         update(x,y);
         if(y<3)
         dfs(x,y+1,step1);
         else
         dfs(x+1,0,step1);

}
int main(){
       char z;
       for(int i=0;i<4;i++){
          for(int j=0;j<4;j++){
             scanf("%c",&z);
             if(z==‘b‘)
                  map[i][j]=0;
                  else
                  map[i][j]=1;
          }
          getchar();
       }
            flag=0;
       for( step=0;step<=16;step++){
           dfs(0,0,0);
           if(flag)
             break;
       }
       if(flag)
           printf("%d\n",step);
       else
       printf("Impossible\n");

   return 0;
}

poj1753枚举

标签:

原文地址:http://www.cnblogs.com/13224ACMer/p/4611558.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!