码迷,mamicode.com
首页 > 其他好文 > 详细

zoj3623 Battle Ships

时间:2015-06-30 22:04:47      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:背包dp

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5
这题比较难想到,看了题解后才恍然大悟。。这里把时间看做容量,所打怪物的血为价值,用dp[j]表示j这个时候最多能打怪物的血量,那么利用完全背包可以得到dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]),其中dp[j-t[i]]是因为刚开始制造要花t[i]时间,后面指的是制造出来后的每一秒可以打多少血。
#include<stdio.h>
#include<string.h>
int max(int a,int b){
	return a>b?a:b;
}
int dp[500];
int main()
{
	int n,m=490,last,i,j;
	int t[50],l[50];
	while(scanf("%d%d",&n,&last)!=EOF)
	{
		for(i=1;i<=n;i++){
			scanf("%d%d",&t[i],&l[i]);
		}
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++){
			for(j=t[i];j<=m;j++){
				dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]);
			}
		}
		for(i=1;i<=m;i++){
			if(dp[i]>=last){
				printf("%d\n",i);break;
			}
		}
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

zoj3623 Battle Ships

标签:背包dp

原文地址:http://blog.csdn.net/kirito_acmer/article/details/46699521

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!