码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1712 ACboy needs your help

时间:2015-07-01 16:07:21      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:背包dp

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
3 4 6

这题是分组背包,对于每一门课,有m种天数的选择,而且选一天和选两天是互斥的,就是说要么不选,要么选k天,所以就在01背包基础上多加一个循环,注意次序,m循环要在k之前,这样才不会发生一门科目重复选多天的情况。

#include<stdio.h>
#include<string.h>
int max(int a,int b){
	return a>b?a:b;
}
int v[106][106],dp[106];
int main()
{
	int n,m,i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==m && n==0)break;
		for(i=1;i<=n;i++){
			for(j=1;j<=m;j++){
				scanf("%d",&v[i][j]);
			}
		}
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++){
			for(j=m;j>=1;j--){
				for(k=1;k<=m;k++){
					if(j>=k && dp[j]<dp[j-k]+v[i][k]){
						dp[j]=dp[j-k]+v[i][k];
					}
				}
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1712 ACboy needs your help

标签:背包dp

原文地址:http://blog.csdn.net/kirito_acmer/article/details/46710163

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!