码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4336压缩率大方的状态DP

时间:2015-07-03 22:03:55      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2141    Accepted Submission(s): 1008
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
1 0.1 2 0.1 0.4
 

Sample Output
10.000 10.500
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<20)+10;
const double eps=1e-4;
int n;
double dp[MAX],p[MAX];

int main(){
	while(~scanf("%d",&n)){
		double p2=1; 
		for(int i=0;i<n;++i){scanf("%lf",&p[i]);p2-=p[i];}
		int bit=1<<n;
		dp[bit-1]=0;
		for(int i=bit-2;i>=0;--i){
			double p1=p2,ans=0;
			for(int j=0;j<n;++j){
				if(i&(1<<j)){//j这张卡片存在 
					p1+=p[j];
				}else{
					ans+=p[j]*(dp[i+(1<<j)]+1);
				}
				dp[i]=(ans+p1)/(1-p1);
			}
		}
		printf("%.4f\n",dp[0]);//这里保留4位小数是由于题目最后一句话 
	}
	return 0;
}



版权声明:本文博客原创文章,博客,未经同意,不得转载。

hdu4336压缩率大方的状态DP

标签:

原文地址:http://www.cnblogs.com/hrhguanli/p/4619724.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!