码迷,mamicode.com
首页 > 其他好文 > 详细

Is It A Tree?-并查集(3)

时间:2015-07-04 11:06:03      阅读:97      评论:0      收藏:0      [点我收藏+]

标签:

B - Is It A Tree?
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
技术分享

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
#include <cstdio>
#include <cstring>
const int  MAX=100010;
int pa[MAX],vis[MAX],x2,y2,i,root=0;
bool flag=1;
int cha(int k)
{
    if(pa[k]!=k)
    {
        pa[k]=cha(pa[k]);
    }
    return pa[k];
}
bool bing(int x,int y)
{
    int x2=cha(x);
    int y2=cha(y);
    if((x2==y2&&x!=y)||x==y)//一旦找到根相同 则之前在其他路就已经出现过,已经绕成了环
    {//自身指向自身不是一课数;
        flag=0;
        return false;
    }
    pa[y2]=x2;
    vis[x]=1;//用于标记它已经出现过
    vis[y]=1;
    return true;
}
void init()
{
    for(i=1; i<=MAX; i++)
    {
        pa[i]=i;
        vis[i]=0;
    }
}
int main()
{
    init();
    int i,j,x,y,m,n,count=0;
    while(scanf("%d%d",&m,&n)!=EOF)
    {

        if(m==-1&&n==-1)
            break;
        if(m==0&&n==0)
        {
            root=0;
            for(i=1; i<MAX; i++)
            {
                if(cha(i)==i&&vis[i])//查找根的个数
                    root++;
            }
            if(root>1)//如果根大于了1 则是森林 不是一棵树
                flag=0;
            count++;
            if(flag==1)
                printf("Case %d is a tree.\n",count);
            else
            {
                printf("Case %d is not a tree.\n",count);
            }
            init();//重新输入下一个Case时 初始化数据
            flag=1;
            continue;

        }
        bing(m,n);
    }
    return 0;
}

 

Is It A Tree?-并查集(3)

标签:

原文地址:http://www.cnblogs.com/tianmin123/p/4620199.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!