码迷,mamicode.com
首页 > 其他好文 > 详细

【USACO1.1.1】Your Ride Is Here

时间:2015-07-05 09:42:45      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:

Your Ride Is Here

It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group‘s turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where "A" is 1 and "Z" is 26. For instance, the group "USACO" would be 21 * 19 * 1 * 3 * 15 = 17955. If the group‘s number mod 47 is the same as the comet‘s number mod 47, then you need to tell the group to get ready! (Remember that "a mod b" is the remainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing "GO" if they match and "STAY" if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

Examples:

Input Output
COMETQ
HVNGAT
GO
ABSTAR
USACO 
STAY

PROGRAM NAME: ride

This means that you fill in your header with:
PROG: ride 
WARNING: You must have ‘ride‘ in this field or the wrong test data (or no test data) will be used.

INPUT FORMAT

Line 1: An upper case character string of length 1..6 that is the name of the comet.
Line 2: An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline at the end of each line but does not have a "return". Sometimes, programmers code for the Windows paradigm of "return" followed by "newline"; don‘t do that! Use simple input routines like "readln" (for Pascal) and, for C/C++, "fscanf" and "fid>>string".

NOTE 2: Because of the extra characters, be sure to leave enough room for a ‘newline‘ (also notated as ‘\n‘) and an end of string character (‘\0‘) if your language uses it (as C and C++ do). This means you need eight characters of room instead of six.

SAMPLE INPUT (file ride.in)

COMETQ
HVNGAT

OUTPUT FORMAT

A single line containing either the word "GO" or the word "STAY".

SAMPLE OUTPUT (file ride.out)

GO

OUTPUT EXPLANATION

Converting the letters to numbers:
C O M E T Q  
3 15 13 5 20 17  
H V N G A T
8 22 14 7 1 20  
then calculate the product mod 47:
3 * 15 * 13 * 5 * 20 * 17 = 994500 mod 47 = 27
8 * 22 * 14 * 7 *  1 * 20 = 344960 mod 47 = 27

Because both products evaluate to 27 (when modded by 47), the mission is ‘GO‘. 


NOCOW上面有翻译就不班门弄斧了 暑假打算USACO做三四章吧 作为备战ICPC的准备 希望能有很大收获

两串字符串 每个字符对应一个数字 分别对字符串每个字符相应数字相乘对47取模 如果最后结果一样就输出“GO” 否则输出“STAY”

简单模拟 因为是第一道题可能难度偏低 

注意USACO提交格式

/*
ID: Alpha Augur
PROG: ride
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <string>
#include <cstdio>
#include <cstring>
using namespace std;

int main(){
//    ofstream fout ("ride.out");
//    ifstream fin ("ride.in");
    freopen("ride.in", "r", stdin);
    freopen("ride.out", "w", stdout);
    char str1[10], str2[10];
    cin >> str1 >> str2;
    int sum1 = 1, sum2 = 1;
    int len1 = strlen(str1);
    int len2 = strlen(str2);
    for(int i = 0; i < len1; ++i){
        sum1 *= (str1[i] - 'A' + 1);
    }
    for(int i = 0; i < len2; ++i){
        sum2 *= (str2[i] - 'A' + 1);
    }
    if((sum1%47) == (sum2%47)){
        cout << "GO" << endl;
    }
    else{
        cout << "STAY" << endl;
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

【USACO1.1.1】Your Ride Is Here

标签:

原文地址:http://blog.csdn.net/u012431590/article/details/46757219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!