码迷,mamicode.com
首页 > 其他好文 > 详细

The Triangle

时间:2015-07-05 12:26:39      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:

描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
样例输出
30
上传者

苗栋栋

//从下往上推

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int n,i,j;
	int a[100][100];
	while(cin>>n)
	{
		for(i=0;i<n;i++)
			for(j=0;j<=i;j++)
				cin>>a[i][j];
		for(i=n-2;i>=0;i--)
		{
			for(j=0;j<=i;j++)
			{
				a[i][j]+=a[i+1][j]>a[i+1][j+1]?a[i+1][j]:a[i+1][j+1];
			}
		}
		cout<<a[0][0]<<endl;

	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

The Triangle

标签:

原文地址:http://blog.csdn.net/phytn/article/details/46762181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!