码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4630:No Pain No Game(线段树)

时间:2015-07-05 23:58:03      阅读:376      评论:0      收藏:0      [点我收藏+]

标签:hdu   线段树   

Problem Description
Life is a game,and you lose it,so you suicide.
But you can not kill yourself before you solve this problem:
Given you a sequence of number a1, a2, ..., an.They are also a permutation of 1...n.
You need to answer some queries,each with the following format:
If we chose two number a,b (shouldn‘t be the same) from interval [l, r],what is the maximum gcd(a, b)? If there‘s no way to choose two distinct number(l=r) then the answer is zero.
 

Input
First line contains a number T(T <= 5),denote the number of test cases.
Then follow T test cases.
For each test cases,the first line contains a number n(1 <= n <= 50000).
The second line contains n number a1, a2, ..., an.
The third line contains a number Q(1 <= Q <= 50000) denoting the number of queries.
Then Q lines follows,each lines contains two integer l, r(1 <= l <= r <= n),denote a query.
 

Output
For each test cases,for each query print the answer in one line.
 

Sample Input
1 10 8 2 4 9 5 7 10 6 1 3 5 2 10 2 4 6 9 1 4 7 10
 

Sample Output
5 2 2 4 3
 

Author
WJMZBMR
 

Source
 



题意:
求区间内的两两gcd里最大的

思路:
我们可以对于每个数求出因子,而在一个区间内出现超过两次的那么必然是一个gcd,这样我们只需要把所有出现超过两次的因子加入线段树中,并更新即可
对于查询,我们可以先按r从小到大排序,离线处理所有答案

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define ls l,mid,lson
#define rs mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 50005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define mpa make_pair
#define lowbit(x) (x&-x)
const int mod = 10007;

struct node
{
    int l,r,id;
} op[N];
int tree[N<<2],a[N],ans[N];

int cmp(node a,node b)
{
    return a.r<b.r;
}

void pushup(int i)
{
    tree[i] = max(tree[lson],tree[rson]);
}

void build()
{
    MEM(tree,0);
}

void updata(int pos,int val,int l,int r,int i)
{
    if(l==r)
    {
        tree[i] = max(tree[i],val);
    }
    else
    {
        int mid = (l+r)/2;
        if(pos<=mid) updata(pos,val,ls);
        else updata(pos,val,rs);
        pushup(i);
    }
}

int query(int L,int R,int l,int r,int i)
{
    if(L<=l&&r<=R)
    {
        return tree[i];
    }
    else
    {
        int mid = (l+r)/2;
        int ans1=0,ans2=0;
        if(L<=mid) ans1=query(L,R,ls);
        if(R>mid) ans2=query(L,R,rs);
        return max(ans1,ans2);
    }
}

int n,m;
int pre[N];

int main()
{
    int t,i,j,k,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        build();
        for(i = 1; i<=n; i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(i = 0; i<m; i++)
        {
            scanf("%d%d",&op[i].l,&op[i].r);
            op[i].id = i;
        }
        sort(op,op+m,cmp);
        MEM(pre,-1);
        int cnt=0;
        for(i = 1; i<=n; i++)
        {
            for(j = 1; j*j<=a[i]; j++)
            {
                if(a[i]%j==0)
                {
                    if(pre[j]!=-1)
                    {
                        updata(pre[j],j,1,n,1);
                    }
                    if(j*j!=a[i]&&pre[a[i]/j]!=-1)
                    {
                        updata(pre[a[i]/j],a[i]/j,1,n,1);
                    }
                    pre[j] = pre[a[i]/j] = i;
                }
            }
            while(cnt<m&&op[cnt].r==i)
            {
                ans[op[cnt].id] = query(op[cnt].l,i,1,n,1);
                cnt++;
            }
        }
        for(i = 0; i<m; i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU4630:No Pain No Game(线段树)

标签:hdu   线段树   

原文地址:http://blog.csdn.net/libin56842/article/details/46767421

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!