码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2266 How Many Equations Can You Find

时间:2015-07-06 14:14:56      阅读:95      评论:0      收藏:0      [点我收藏+]

标签:

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 644    Accepted Submission(s): 424


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
123456789 3 21 1
 

Sample Output
18 1
 
题意:告诉一个字符串,在任意两个数字之间可以添加 + 或者 -  ,使得整体运算结果等于N
思路:从起始位置到当前位置的搜索,注意第一个字符前面不能加符号

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 10009
typedef long long ll;

using namespace std;

char s[N];
ll n;
int len;
int ans;
int a[N];

void dfs(ll x,int pos)
{
    if(x==n && pos==len)
    {
        ans++;
        return;
    }

    ll tmp=0;
    for(int i=pos;i<len;i++)
    {
        tmp=tmp*10+a[i];
        dfs(x+tmp,i+1);<span style="font-family: Arial, Helvetica, sans-serif;">//temp=0并且x=0的时候,相当于添加了第一个字符</span>
<span style="font-family: Arial, Helvetica, sans-serif;">                if(pos!=0)//第一个字符前面不能使用符号</span>

        dfs(x-tmp,i+1);
    }

}

int main()
{
    while(~scanf("%s %I64d",s,&n))
    {
        len=strlen(s);

        for(int i=0;i<len;i++)
        a[i]=s[i]-'0';

        ans=0;
        dfs(0,0);
        printf("%d\n",ans);

    }
    return 0;
}








版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 2266 How Many Equations Can You Find

标签:

原文地址:http://blog.csdn.net/wust_zjx/article/details/46773441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!