码迷,mamicode.com
首页 > 其他好文 > 详细

uva573 The Snail

时间:2015-07-06 14:21:01      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:uva107   uva573   

The Snail
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status Practice UVA 573
Appoint description:

Description
Download as PDF

A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% × 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day’s climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail’s height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

Day Initial Height Distance Climbed Height After Climbing Height After Sliding
1 0’ 3’ 3’ 2’
2 2’ 2.7’ 4.7’ 3.7’
3 3.7’ 2.4’ 6.1’ -

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail’s height will exceed the height of the well or become negative.) You must find out which happens first and on what day.

Input
The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail’s climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.

Output

For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2

蜗牛 在一个井里,白天向上爬,晚上会下滑,同时由于疲劳,每天能爬的高度在减小,问你他能不能出来,如果可以的话,出来的日子,或者失败的日子
直接模拟即可
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int maxn=55;
typedef long long LL;
int a[maxn];
int main(){
    #ifndef ONLINE_JUDGE
    //freopen("Text//in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    double h,u,d,f;
    while(scanf("%lf%lf%lf%lf",&h,&u,&d,&f)&&(h||u||d||f)){
        double s=0;
        int ans=0;
        f=u*f/100.0;
        int t;
        while(true){
            if(u>=0)s+=u;
            ans++;
            if(s>h){
                printf("success on day %d\n",ans);break;
            }
            s-=d;
            if(s<0){
                printf("failure on day %d\n",ans);break;
            }
            u-=f;
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva573 The Snail

标签:uva107   uva573   

原文地址:http://blog.csdn.net/u013167299/article/details/46772787

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!