码迷,mamicode.com
首页 > 其他好文 > 详细

hdu Phone List 字典树的前缀判断

时间:2015-07-06 19:51:42      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:字典树

题链:http://acm.hdu.edu.cn/showproblem.php?pid=1671


Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12763    Accepted Submission(s): 4341


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO YES
 



题意:给出n串字符串,问其中是否会有某串字符串是另一个字符串的前缀。

做法:不断加到Trie里,然后不断判断是不是其他字符串的前缀,或者已有的是不是自己的前缀。



#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAX 10

struct Trie   
{   
    Trie *next[MAX];   
    int v;   //根据需要变化
};   
 
Trie root;

void createTrie(char *str)
{
    int len = strlen(str);
    Trie *p = &root, *q;
    for(int i=0; i<len; ++i)
    {
        int id = str[i]-'0';
        if(p->next[id] == NULL)
        {
            q = (Trie *)malloc(sizeof(Trie));
            q->v = 1;    //初始v==1
            for(int j=0; j<MAX; ++j)
                q->next[j] = NULL;
            p->next[id] = q;
            p = p->next[id];
        }
        else
        {
            p->next[id]->v++;
            p = p->next[id];
        }
    }
    p->v = -1;   //若为结尾,则将v改成-1表示
}

int findTrie(char *str)
{
    int len = strlen(str);
    Trie *p = &root;
	if(p==NULL)
		return 0;
    for(int i=0; i<len; ++i)
    {
        int id = str[i]-'0';
        p = p->next[id];
        if(p == NULL)   //若为空集,表示不存以此为前缀的串
            return 0;
        if(p->v == -1&&i==len-1) //有一样的串
            return -1;
		if(p->v == -1)//字符集中已有串是此串的前缀
			return -1;
	}
    return -1;   //此串是字符集中某串的前缀
}
int dealTrie(Trie* T)
{
    int i;
    if(T==NULL)
        return 0;
    for(i=0;i<MAX;i++)
    {
        if(T->next[i]!=NULL)
		{
            dealTrie(T->next[i]);
			T->next[i]=NULL;
		}
    }
	if(T!=&root)
    free(T);
    return 0;
}

 

char str[100];
int main()
{
	int t; 
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int flag=1; 
		while(n--)
		{
			scanf("%s",str);
			int tem=findTrie(str);
			if(tem==-1)
				flag=0;
			createTrie(str); 
		}
		if(flag==0)
			puts("NO");
		else
			puts("YES"); 
		dealTrie(&root);
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu Phone List 字典树的前缀判断

标签:字典树

原文地址:http://blog.csdn.net/u013532224/article/details/46777745

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!