码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1710 Binary Tree Traversals 前序遍历和中序推后序

时间:2015-07-06 23:31:25      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:后序历遍

题链;http://acm.hdu.edu.cn/showproblem.php?pid=1710

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4205    Accepted Submission(s): 1904


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
技术分享
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
7 4 2 8 9 5 6 3 1
 

题意:给出前序历遍和中序遍历的顺序,来推导后序遍历的顺序。
做法:把握两个要点,前序是 先根历遍的,所以前序的第一个是根。然后这个根把中序分为两半,左边是左子树,右边是右子树。然后递归下就ok了。


#include <cstdio>
#include <algorithm>
using namespace std;

struct tree
{
	struct tree* l;
	struct tree* r;
	int val; 
	tree()
	{
		l=NULL;
		r=NULL;
	}
}; 

int pre[1010],in[1010];
int n;
tree* root;
void build(int num,int l,int r,tree *rt)//pre num   in_l  in_r
{
	int flag=-1;
	while(flag==-1)
	{
		for(int i=l;i<=r;i++)
		{
			if(pre[num]==in[i])
				flag=i;
		}
		if(flag==-1)
			num++;
	}
	if(flag-l>0)
	{
		rt->l=(tree*)malloc(sizeof(tree));
		*(rt->l)=tree();
		build(num+1,l,flag-1,rt->l);
	}
	if(r-flag>0)
	{
		rt->r=(tree*)malloc(sizeof(tree));
		*(rt->r)=tree();
		build(num+1,flag+1,r,rt->r);
	}
	rt->val=pre[num];
}

void post(tree* nw)
{
	if(nw->l!=NULL)
	post(nw->l);
	if(nw->r!=NULL)
	post(nw->r);

	if(nw==root)
		printf("%d",nw->val);
	else
		printf("%d ",nw->val);

}

void del(tree* nw)
{
	if(nw->l!=NULL)
	del(nw->l);
	if(nw->r!=NULL)
	del(nw->r);
	free(nw);
}

int main() 
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
			scanf("%d",&pre[i]);
		for(int i=0;i<n;i++)
			scanf("%d",&in[i]); 
		root=(tree*)malloc(sizeof(tree));
		*root=tree();
		build(0,0,n-1,root); 
		post(root);
		puts(""); 
		del(root);  
	} 
	return 0;
} 




版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1710 Binary Tree Traversals 前序遍历和中序推后序

标签:后序历遍

原文地址:http://blog.csdn.net/u013532224/article/details/46779613

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!