标签:hdu bestcoder 入门
题目链接:Tom and paper
题面:
Tom and paper
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 679 Accepted Submission(s): 432
Problem Description
There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
Input
In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
T≤10,n≤109
Output
For each case, output a integer, indicates the answer.
Sample Input
Sample Output
Source
解题:
若周长固定,取半值附近的值,面积最大。反之,取平方根附近,周长最长。
代码:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int t,n,root;
cin>>t;
while(t--)
{
cin>>n;
root=sqrt(1.0*n);
for(int i=root;;i--)
{
if(n%i==0)
{
cout<<2*(i+n/i)<<endl;
break;
}
}
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDU 5224 Tom and paper(BestCoder Round #40)
标签:hdu bestcoder 入门
原文地址:http://blog.csdn.net/david_jett/article/details/46780405