码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ3374 String Problem [KMP最小循环节点]+[最小(大)表示法]

时间:2014-05-03 21:28:56      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:hdoj3374

 

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1442    Accepted Submission(s): 645


Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 


 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 


 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 


 

Sample Input
abcder aaaaaa ababab
 


 

Sample Output
1 1 6 1 1 6 1 6 1 3 2 3

 

 

 

#include <stdio.h>
#include <string.h>
#define maxn 1000002
char str[maxn];
int len, next[maxn];

void getNext(){
	int i = 0, j = -1;
	next[0] = -1;
	while(i < len){
		if(j == -1 || str[i] == str[j]){
			++i; ++j;
			next[i] = j;
		}else j = next[j];
	}
}

int minR(){
	int i = 0, j = 1, k = 0, t;
	while(i < len && j < len && k < len){
		t = str[i+k >= len ? i+k-len : i+k] - 
			str[j+k >= len ? j+k-len : j+k];
		if(t == 0) ++k;
		else{
			if(t > 0) i += k + 1;
			else j += k + 1;
			k = 0;
			if(i == j) ++j;
		}
	}
	return i < j ? i : j;
}

int maxR(){
	int i = 0, j = 1, k = 0, t;
	while(i < len && j < len && k < len){
		t = str[i+k >= len ? i+k-len : i+k] - 
			str[j+k >= len ? j+k-len : j+k];
		if(t == 0) ++k;
		else{
			if(t > 0) j += k + 1;
			else i += k + 1;
			k = 0;
			if(i == j) ++j;
		}
	}
	return i < j ? i : j;
}

int main(){
	int minlen, num;
	while(scanf("%s", str) == 1){
		len = strlen(str);
		getNext();
		if(len % (len - next[len]) == 0) //最小循环节点
			minlen = len - next[len];
		else minlen = len;
		num = len / minlen;
		printf("%d %d %d %d\n", minR()+1, num, maxR()+1, num);
	}
	return 0;
}


 

 

HDOJ3374 String Problem [KMP最小循环节点]+[最小(大)表示法],布布扣,bubuko.com

HDOJ3374 String Problem [KMP最小循环节点]+[最小(大)表示法]

标签:hdoj3374

原文地址:http://blog.csdn.net/chang_mu/article/details/24929077

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!