码迷,mamicode.com
首页 > 其他好文 > 详细

Count the Colors

时间:2015-07-08 22:42:09      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:

B - Count the Colors
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can‘t be seen, you shouldn‘t print it.

Print a blank line after every dataset.


Sample Input



5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output



1 1
2 1
3 1

1 1

0 2
1 1


/*
Author: 2486
Memory: 232 KB		Time: 110 MS
Language: C++ (g++ 4.7.2)		Result: Accepted
*/
//暴力可过,或者是线段树
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn=8000+5;
int n,a,b,c,ans[maxn],col[maxn];
int main() {
    while(~scanf("%d",&n)) {
        memset(ans,0,sizeof(ans));
        memset(col,0,sizeof(col));
        int Max=0;
        for(int i=0; i<n; i++) {
            scanf("%d%d%d",&a,&b,&c);
            for(int j=a; j<b; j++) {
                col[j]=c+1;
            }
            Max=max(Max,b);
        }
        for(int i=0; i<=Max; i++) {
            while(i!=0&&col[i]&&col[i]==col[i-1]) {
                i++;
            }
            if(col[i]) {
                ans[col[i]-1]++;
            }
        }
        for(int i=0; i<=8001; i++) {
            if(ans[i]) {
                printf("%d %d\n",i,ans[i]);
            }
        }
        printf("\n");
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Count the Colors

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/46808129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!