码迷,mamicode.com
首页 > 其他好文 > 详细

1041. Be Unique (20)

时间:2015-07-10 15:14:42      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:算法   pat   vector   map   

题目如下:

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

题目要求找出一个序列中第一个在序列中只出现了一次的数,实现方法很简单,使用map记录每个数出现的次数,然后使用vector记录输入顺序,依次判断即可。

#include <iostream>
#include <map>
#include <vector>
#include <stdio.h>

using namespace std;

int main()
{
    map<int,int> numMap;
    vector<int> nums;
    int N;
    cin >> N;
    int num;
    for(int i = 0; i < N; i++){
        scanf("%d",&num);
        numMap[num]++;
        nums.push_back(num);
    }
    num = - 1;
    for(int i = 0; i < nums.size(); i++){
        if(numMap[nums[i]] == 1){
            num = nums[i];
            break;
        }
    }
    if(num == -1) cout << "None" << endl;
    else cout << num << endl;

    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

1041. Be Unique (20)

标签:算法   pat   vector   map   

原文地址:http://blog.csdn.net/xyt8023y/article/details/46830301

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!