码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ1458】Common Subsequence

时间:2015-07-10 22:25:25      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:


Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42100   Accepted: 16996

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

公共子序列 简单DP

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 1010;
char str1[maxn], str2[maxn];
int ma[maxn][maxn];

int main(){
	while(scanf("%s%s", str1+1, str2+1)!=EOF){
		memset(ma, 0, sizeof(ma));
		int len1 = strlen(str1+1);
		int len2 = strlen(str2+1);

		for(int i = 1; i <= len1; ++i){
			for(int j = 1; j <= len2; ++j){
				if(str1[i] == str2[j]){
					ma[i][j] = ma[i-1][j-1] + 1;
				}
				else{
					ma[i][j] = max(ma[i-1][j], ma[i][j-1]);
				}
			}
		}

		printf("%d\n", ma[len1][len2]);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

【POJ1458】Common Subsequence

标签:

原文地址:http://blog.csdn.net/u012431590/article/details/46834031

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!