码迷,mamicode.com
首页 > 其他好文 > 详细

HDU(1241)

时间:2015-07-11 09:19:06      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16742    Accepted Submission(s): 9626

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.
 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
 
Sample Output
0
1
2

2

//初识dfs实在困难,只好猛刷题了。。。

//这题的主要思路找到一个油地只好边从油地的位置开始搜索上下左右斜对角搜索,如果发现油地标记为1

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int n,m;
int vis[110][110];
char c[110][110];

void dfs(int x,int y)
{
    if(vis[x][y])return;  //已标记过
    if(x>=n||y>=m||x<0||y<0) return;  //边界条件
    if(c[x][y]=='@')  //傻傻的只知道写多个,不知道用循环。。。
    {
        vis[x][y]=1;  //找到邻近的油地
        dfs(x+1,y);
        dfs(x-1,y);
        dfs(x,y+1);
        dfs(x,y-1);
        dfs(x-1,y-1);
        dfs(x+1,y+1);
        dfs(x-1,y+1);
        dfs(x+1,y-1);
    }

}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            return 0;
        int cnt=0;
        for(int i=0;i<110;i++)
            for(int k=0;k<110;k++)
            {
                vis[i][k]=0;
                c[i][k]=0;
            }
        getchar();  // 有坑 多了一个空格
        for(int i=0;i<n;i++)
        {
            for(int k=0;k<m;k++)
            {
                cin >> c[i][k];
            }
        }
        for(int i=0;i<n;i++)
        {
            for(int k=0;k<m;k++)
            {
                if(c[i][k]=='@'&&!vis[i][k])  //未被标记过的
                {

                    cnt++;
                    dfs(i,k);
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU(1241)

标签:

原文地址:http://blog.csdn.net/a73265/article/details/46835175

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!