码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3371 kruscal/prim求最小生成树 Connect the Cities 大坑大坑

时间:2015-07-11 22:45:06      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:

这个时间短  700多s
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
   int u;
   int v;
   int w;
}que[100000];
int father[505];
bool cmp(struct node a,struct node b){
    return a.w<b.w;
}
void init(int n){
    for(int i=1;i<=n;i++)
    father[i]=i;
}
int find(int u){
    if(father[u]!=u)
    father[u]=find(father[u]);
    return father[u];
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
       int n,m,k;
       int edge=0,sum=0;
       scanf("%d%d%d",&n,&m,&k);
       init(n);
       for(int i=0;i<m;i++){
          scanf("%d%d%d",&que[i].u,&que[i].v,&que[i].w);
       }
       sort(que,que+m,cmp);
       for(int i=1;i<=k;i++){
           int cnt,root;
           scanf("%d%d",&cnt,&root);
           for(int j=1;j<cnt;j++){
              int x;
              scanf("%d",&x);
              int c1=find(x),c2=find(root);
              if(c1!=c2){
                  father[c1]=c2;
              }
           }
       }
      for(int i=1;i<=n;i++)
      if(father[i]==i)
      edge++;
      bool flag=false;
      for(int i=0;i<m;i++){
          int tx=find(que[i].u),ty=find(que[i].v);
          if(tx!=ty){
              father[tx]=ty;
              sum+=que[i].w;
              edge--;
          }
          if(edge==1){
            flag=true;
            break;
          }

      }
      if(flag)
      printf("%d\n",sum);
      else
      printf("-1\n");

    }
    return 0;
}

 

Connect the Cities

Time Limit: 1000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1

Source

HDOJ Monthly Contest – 2010.04.04
 
 
 
 
本题judge系统绝对坑的你无语,同一个代码,一会交上去过了,过了一会交上去就超时,绝对TLE的你没有脾气
什么也不想说了。在各种虚拟Oj里面提交,也是出现同样的问题,真是无语了
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
   int u,v,w;
}que[105000];
int father[505];
bool cmp( node a, node b){
   return a.w<b.w;
}
void init(int n){
     for(int i=1;i<=n;i++)
       father[i]=i;
}
int find(int u){
   if(father[u]!=u){
       father[u]=find(father[u]);
   }
   return father[u];
}

int main(){
   int t;
   scanf("%d",&t);
   while(t--){
       int n,m,k;///
       int sum,edge;//这些变量我一定义在外部就会超时,只能定义在内部,那样也是飘过,980多s,好险好险
       int uu,vv,ww;
      scanf("%d%d%d",&n,&m,&k);
      init(n);
      for(int i=0;i<m;i++){
          scanf("%d%d%d",&uu,&vv,&ww);
          que[i].u=uu;
          que[i].v=vv;
          que[i].w=ww;
      }
       sort(que,que+m,cmp);
      int x,zz,dd;
      for(int i=1;i<=k;i++){
               scanf("%d%d",&x,&zz);
        for(int j=1;j<x;j++){
              scanf("%d",&dd);
              int c1=find(zz),c2=find(dd);
              if(c1!=c2)
              father[c2]=c1;
        }
      }
      edge=0;
      for(int i=1;i<=n;i++){
      if(father[i]==i)
      edge++;
      }//此时只需要判断还有几个相等,其中另一个含义就是看这些个点分成了几堆,不妨设为k堆,那么只需要k-1条线便可以将其他的点连接在一起,即其他的堆
    sum=0;
    bool flag=false;
   for(int i=0;i<m;i++){
       int a1=find(que[i].u);
       int a2=find(que[i].v);
       if(a1!=a2){
           father[a1]=a2;
              sum+=que[i].w;
              edge--;
       }
       if(edge==1){
          flag=true;
          break;
        }
   }

     if(flag)
     printf("%d\n",sum);
     else
     printf("-1\n");
   }
   return 0;
}

 

HDU 3371 kruscal/prim求最小生成树 Connect the Cities 大坑大坑

标签:

原文地址:http://www.cnblogs.com/13224ACMer/p/4639351.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!