标签:
beap总是自诩敢说又敢做,又到了情人节,为了体现自己的勇气可嘉,beap决定给自己喜欢的女生买玫瑰花,以此表达自己的爱意。到花店里,他发现一共有K种花,同时他从网上得知,送N朵花的花语是LOVE,所以他决定在所有的花里面选N朵出来送给心爱的女生,但是又为了显示自己买了那么多种花,他决定这K种花一定要都出现在这N朵里面。现在beap将这些花排成一排,他想知道满足条件的N朵花,能摆成多少种形态呢?
多组测试数据
每组测试数据包含两个整数N,K(0<N≤1000, 0<K≤30),N代表花的朵数,K代表花的种类数。
对于每个N,K,输出答案mod 123456781。
Sample Input | Sample Output |
---|---|
1 1 2 2 |
1 2 |
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stack>
#include <map>
#include <set>
#include <queue>
#include <iomanip>
#include <string>
#include <ctime>
typedef unsigned char byte;
#define pb push_back
#define input_fast std::ios::sync_with_stdio(false);std::cin.tie(0)
#define local freopen("in.txt","r",stdin)
using namespace std;
const int maxn = 1e3 + 50;
const long long mod = 123456781;
long long kp[maxn][maxn];
long long dp[maxn][35];
long long counter(int x,int y)
{
if (kp[x][y] != -1)
return kp[x][y];
long long & ans = kp[x][y];
if (x == y || y == 0) return ans = 1;
return ans = (counter(x-1,y-1) + counter(x-1,y) ) % mod;
}
long long dfs(int x,int y)
{
if (dp[x][y] != -1)
return dp[x][y];
long long & ans = dp[x][y] = 0;
if (y == 0) return (ans = (x==0));
for(int i = 1 ; i <= x - y + 1 ; ++ i)
{
ans += counter(x,i) * dfs(x - i , y - 1);
if (ans >= mod)
ans %= mod;
}
return ans;
}
int main(int argc,char *argv[])
{
int n , k ;
memset(dp , -1 , sizeof(dp));
memset(kp , -1 , sizeof(kp));
while(~scanf("%d%d",&n,&k))
{
if (n < k) printf("0\n");
else
printf("%lld\n",dfs(n,k));
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/Xiper/p/4639636.html