码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5280 Senior's Array

时间:2015-07-12 12:45:39      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:dp

Senior‘s Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 528    Accepted Submission(s): 209


Problem Description
One day, Xuejiejie gets an array A技术分享. Among all non-empty intervals of A技术分享, she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval---[L,R]技术分享 is calculated by this formula : beauty(L,R) = A[L]+A[L+1]++A[R]技术分享. The most beautiful interval is the one with maximum beauty.

But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one value of the element of A技术分享 to P技术分享 . Xuejiejie plans to come to see him in tomorrow morning.

Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).
 

Input
In the first line there is an integer T技术分享, indicates the number of test cases.

In each case, the first line contains two integers n技术分享 and P技术分享. n技术分享 means the number of elements of the array. P技术分享 means the value Mini-Sun can change to.

The next line contains the original array.

1n1000技术分享, ?10技术分享9技术分享A[i],P10技术分享9技术分享技术分享
 

Output
For each test case, output one integer which means the most beautiful interval‘s beauty after your change.
 

Sample Input
2 3 5 1 -1 2 3 -2 1 -1 2
 

Sample Output
8 2
 

Source
题意: 给一个数组a[n],问使数组中某一个值变成P,得到a[l]+a[l+1]+......+a[r]最大是多少。
#include<stdio.h>
const int N = 1005;
const int inf = 1<<29;
int main(){
    __int64 dp[N],P,a[N],ans;
    int n,T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%I64d",&n,&P);
        for(int i=1; i<=n; i++)
            scanf("%I64d",&a[i]);

        ans=-inf;
        dp[0]=0;

        for(int i=1; i<=n; i++)
        {
            int tmp=a[i];
            a[i]=P;
            for(int j=1; j<=n; j++)
            {
                if(dp[j-1]>0)
                    dp[j]=dp[j-1]+a[j];
                else
                    dp[j]=a[j];
                if(dp[j]>ans)
                    ans=dp[j];
            }
            a[i]=tmp;
        }
        printf("%I64d\n",ans);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5280 Senior's Array

标签:dp

原文地址:http://blog.csdn.net/u010372095/article/details/46849269

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!