码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5281 Senior's Gun

时间:2015-07-12 21:43:42      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Senior‘s Gun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 616    Accepted Submission(s): 241


Problem Description
Xuejiejie is a beautiful and charming sharpshooter.

She often carries n技术分享 guns, and every gun has an attack power a[i]技术分享.

One day, Xuejiejie goes outside and comes across m技术分享 monsters, and every monster has a defensive power b[j]技术分享.

Xuejiejie can use the gun i技术分享 to kill the monster j技术分享, which satisfies b[j]a[i]技术分享, and then she will get a[i]?b[j]技术分享 bonus .

Remember that every gun can be used to kill at most one monster, and obviously every monster can be killed at most once.

Xuejiejie wants to gain most of the bonus. It‘s no need for her to kill all monsters.
 

Input
In the first line there is an integer T技术分享, indicates the number of test cases.

In each case:

The first line contains two integers n技术分享, m技术分享.

The second line contains n技术分享 integers, which means every gun‘s attack power.

The third line contains m技术分享 integers, which mean every monster‘s defensive power.

1n,m100000技术分享, ?10技术分享9技术分享a[i],b[j]10技术分享9技术分享技术分享
 

Output
For each test case, output one integer which means the maximum of the bonus Xuejiejie could gain.
 

Sample Input
1 2 2 2 3 2 2
 

Sample Output
1
 

Source
 

题意:

有n把枪,m只怪物,每把抢都有一个能量值,每个怪物都有一个耗能值,现在用n把枪去打怪物,每把枪只能用一次,怪物只能打一次,用每i把枪打第j只怪物得到能量值为a[i]-b[j],前提a[i]>=b[j],枪可以不用完,怪物也可以不打完,问最多能得多少的能量值。
解题:枚举用k把枪去打k只怪物,那么每把枪都是最大能量值,每只怪物都是耗能最少的。
<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
using namespace std;
const int N = 100005;
bool cmp(int a,int b){
    return a>b;
}
__int64 ans,a[N],b[N];
int main()
{
    
    int T,n,m;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%I64d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%I64d",&b[i]);
        sort(a,a+n,cmp);
        sort(b,b+m);
        int k=0;
        ans=-(1<<29);
        while(k<n&&k<m){
            if(k!=0){
                a[k]+=a[k-1];
                b[k]+=b[k-1];
            }
            if(ans<a[k]-b[k])
                ans=a[k]-b[k];
            k++;
        }
        printf("%I64d\n",ans);
    }
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 5281 Senior's Gun

标签:

原文地址:http://blog.csdn.net/u010372095/article/details/46853179

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!