码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1171 Big Event in HDU (多重背包变形)

时间:2015-07-12 23:19:58      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:hdu   动态规划   多重背包   

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27961    Accepted Submission(s): 9847

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1171


题目大意:有n种物品,价值为vi的有mi个,现在要买两份,要求第一份物品总价值大于等于第二份,且两份物品总价值的差最小


题目分析:多重背包问题,递减枚举价值,一旦当前价值超过了总价值的一半,计算差值取最小


#include <cstdio>
int m[55], v[55];

int main()
{
    int n;
    while(scanf("%d", &n) != EOF && n > 0)
    {
        int sum = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d", &v[i], &m[i]);
            sum += v[i] * m[i];
        }
        int mi = sum, ans = v[0];
        for(int i = 0; i < n; i++)
            for(int j = sum; j >= v[i]; j--)
                for(int k = 0; k <= m[i]; k++)
                    if(j >= k * v[i])
                        if(k && j % (k * v[i]) == 0 && j * 2 >= sum && 2 * j - sum < mi)
                        {
                            mi = 2 * j - sum;
                            ans = j;
                        }
        printf("%d %d\n", ans, sum - ans);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1171 Big Event in HDU (多重背包变形)

标签:hdu   动态规划   多重背包   

原文地址:http://blog.csdn.net/tc_to_top/article/details/46854357

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!