码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1579 Function Run Fun(深搜+记忆化)

时间:2014-07-06 09:44:41      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:数学   hdu   dfs   

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1579


Problem Description
We all love recursion! Don‘t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
  1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
  w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
  w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
 
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
 
Output
Print the value for w(a,b,c) for each triple. 

Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1
 
Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1


代码一如下:

#include <cstdio>
#include <cstring>
int dp[57][57][57];
int dfs(int a, int b, int c)
{
	if(a<=0 || b<=0 || c<=0)
		return 1;
	if(a>20 || b>20 || c>20)
		return dfs(20,20,20);
	if(dp[a][b][c])
		return dp[a][b][c];
	if(a < b && b < c)
		dp[a][b][c]=dfs(a,b,c-1)+dfs(a,b-1,c-1)-dfs(a,b-1,c);
	else
		dp[a][b][c]=dfs(a-1,b,c)+dfs(a-1,b-1,c)+dfs(a-1,b,c-1)-dfs(a-1,b-1,c-1);
	return dp[a][b][c];
}
int main()
{
	int a, b, c;
	while(~scanf("%d%d%d",&a,&b,&c))
	{
		if(a == -1 && b == -1 && c == -1)
			break;
		int ans = dfs(a,b,c);
		printf("w(%d, %d, %d) = %d\n",a,b,c,ans);
	}
	return 0;
}

代码二如下:

#include <cstdio>
#define N 20
int a,b,c,w[N+1][N+1][N+1];
int dp(int a,int b,int c)
{
    int i,j,k;
	
    if (a<=0 || b<=0 || c<=0)
        return 1;
    if (a>20 || b>20 || c>20)
        a=b=c=20;
    for (i=0;i<=N;i++)
        for (j=0;j<=N;j++)
            w[0][i][j]=w[i][0][j]=w[i][j][0]=1;
		for (i=1;i<=a;i++)
			for (j=1;j<=b;j++)
				for (k=1;k<=c;k++)
					if (i<j && j<k)
						w[i][j][k]=w[i][j][k-1]+w[i][j-1][k-1]-w[i][j-1][k];
					else
						w[i][j][k]=w[i-1][j][k]+w[i-1][j-1][k]+w[i-1][j][k-1]-w[i-1][j-1][k-1];
					return w[a][b][c];
}

int main()
{
    while (~scanf("%d %d %d",&a,&b,&c))
	{
		if(a == -1 && b == -1 && c == -1)
			break;
		int ans = dp(a,b,c);
        printf("w(%d, %d, %d) = %d\n",a,b,c,ans);
	}
    return 0;
}


hdu1579 Function Run Fun(深搜+记忆化),布布扣,bubuko.com

hdu1579 Function Run Fun(深搜+记忆化)

标签:数学   hdu   dfs   

原文地址:http://blog.csdn.net/u012860063/article/details/37076755

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!