码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1076-An Easy Task(Debian下水题测试.....)

时间:2015-07-13 22:30:54      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   hdu   水题   


 

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17062    Accepted Submission(s): 10902


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
3 2005 25 1855 12 2004 10000
 

Sample Output
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1021 1097 1061 1032 1170


题目的意思很简单:
就是让你求出从Y开始的年份第N个闰年......甚至不用考虑时间复杂度,强行AC!
主要是Debian下命令行不熟悉,费了不少时间......



#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,Y,N;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&Y,&N);
        while(1)
        {
            if((Y%4==0&&Y%100!=0)||(Y%400==0))
            {
                N--;
            }
            if(N==0)
                break;
            Y++;
        }
        printf("%d\n",Y);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU-1076-An Easy Task(Debian下水题测试.....)

标签:acm   c++   hdu   水题   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46867301

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!