码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1092-A+B for Input-Output Practice (IV)(继续!)

时间:2015-07-15 15:08:31      阅读:100      评论:0      收藏:0      [点我收藏+]

标签:怪就怪平时水的也挺多啊   up主已经疯了   

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76182    Accepted Submission(s): 40771


Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
 

Sample Output
10 15
 

Author
lcy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1093 1094 1095 1096 1061 


#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,a,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            sum+=a;
        }
        printf("%d\n",sum);
    }
    return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU-1092-A+B for Input-Output Practice (IV)(继续!)

标签:怪就怪平时水的也挺多啊   up主已经疯了   

原文地址:http://blog.csdn.net/qq_16542775/article/details/46892489

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!