码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 2770 Burn the Linked Camp 差分约束

时间:2015-07-15 22:53:04      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:差分约束

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2770

Burn the Linked Camp

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei‘s wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let‘s go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei‘s troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei‘s Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1??Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei‘s army from Lu Xun‘s observation. However, Lu Xun‘s estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations

和这题一样

http://blog.csdn.net/u013532224/article/details/46897989

就是在相邻点之间建边的时候有点不一样。

题意:

神陆逊 计算 刘备连营的兵力。

给出了刘备n个连营的 最大兵力Ci。

然后 又得到情报 知道  i到j 连营的兵力 至少是k。

然后计算所有人数 最少有多少


做法:(括号内表示该点及其左边所有人数和!!!!!!!!!!)

我们从0点出发。

到1号点,因为连营有最大兵力限制。


所以  (1)-(0)<=C1

又因为 后面的人数前缀和 肯定大于前面的

所以(0)-(1)<=0

然后后面n个点之间都有这种关系。

(i)-(i-1)<=Ci

(i-1)-(i)<=0

然后根据差分约束,建边。


然后i到j点的兵力不超过k

说明 

(j)-(i-1)>=k

(i-1)-(j)<=-k

然后建边。


计算人数和的最小值,

所以就是 计算 (n)-(0)>=?

加个负号

(0)-(n)<=-?

跑个最短路,答案取负就行了。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
 
#define VM 6000
#define EM 80005
#define inf 0x7f7f7f7f
int head[VM],ep;
struct edge
{
    int v,w,next;
}e[EM];

void addedge(int cu,int cv,int cw)
{
    ep ++;
    e[ep].v = cv;
    e[ep].w = cw;
    e[ep].next = head[cu];
    head[cu] = ep;
}

int spfa (int n,int sta,int ee)
{
    int vis[VM],stack[VM],dis[VM],vn[VM];
    memset(vis,0,sizeof(vis));
	memset(dis,inf,sizeof dis); 
	//for(int i=1;i<=n;i++)
	//dis[i]=-inf;
	memset(vn,0,sizeof vn);
	vn[sta]=1;
    dis[sta] = 0;
    vis[sta] = 1;
    int top = 1;
    stack[0] = sta;
    while (top)
    { 
        int u = stack[--top];
		if(vn[u]>n)
			return -inf;
        vis[u] = 0;
        for (int i = head[u];i != -1;i = e[i].next)
        {
            int v = e[i].v;
            if (dis[v] > dis[u] + e[i].w)
            {
                dis[v] = dis[u] + e[i].w;
                if (!vis[v])
                {
                    vis[v] = 1;
					vn[v]++;
                    stack[top++] = v;
                }
            }
        }
    } 
    return dis[ee];
}
int main ()
{ 
    int n,m,v1,v2,cost;
	int ml,md;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		ep = 0;
		memset (head,-1,sizeof(head));
		 
		for(int i=1;i<=n;i++)
		{
			int tem;
			scanf("%d",&tem);
			addedge(i,i-1,0);//(i)-(i+1)《=0   后面的点数大 
			addedge(i-1,i,tem);//(i+1)-(i)《=1   i+1 最多放一个 
		}
		for(int i=0;i<m;i++)
		{
			int u,v,lim;
			scanf("%d%d%d",&u,&v,&lim); //v-u<=lim  
			addedge(v,u-1,-lim);//   v-(u-1)>=lim   (u-v)<=lim
		}
		 
		int ans=spfa(n+1,n,0);

		if(ans==-inf)
			puts("Bad Estimations");//负环 有矛盾条件
		else if(ans==inf)//无限多
			puts("-2");
		else
			printf("%d\n",-ans);
	}
	return 0;
}









版权声明:本文为博主原创文章,未经博主允许不得转载。

ZOJ 2770 Burn the Linked Camp 差分约束

标签:差分约束

原文地址:http://blog.csdn.net/u013532224/article/details/46898225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!