码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4788 Hard Disk Drive

时间:2015-07-15 22:57:29      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:入门   区域赛   概率   

题目链接:HDU 4788 Hard Disk Drive 


题面:

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1872    Accepted Submission(s): 1028


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input
2 100[MB] 1[B]
 

Sample Output
Case #1: 4.63% Case #2: 0.00%
Hint
技术分享
 

Source


解题:

  磁盘和系统对于文件大小定义不同,问为n x单位的磁盘时,损失率为多少。

  其实和文件大小无关,只与单位有关,每进一个单位乘以1000/1024即可。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <cmath>
#include <cstdlib>
#include <set>
#include <algorithm>
#include <string>
#include <iomanip>
#define LL long long
using namespace std;
double loss=1000.0/1024;
double ans[10]={1.0};
void cal()
{
	for(int i=1;i<10;i++)
	{
      ans[i]=ans[i-1]*loss;
	}
}
void show(int p)
{
	cout<<fixed<<setprecision(2)<<(1-ans[p])*100<<"%\n";
}
int main()
{
	int n,t;
	cal();
	cin>>t;
	string s;
	for(int i=1;i<=t;i++)
	{
		cout<<"Case #"<<i<<": ";
		cin>>n>>s;
		if(s[1]=='B')show(0);
		else if(s[1]=='K')show(1);
		else if(s[1]=='M')show(2);
		else if(s[1]=='G')show(3);
		else if(s[1]=='T')show(4);
		else if(s[1]=='P')show(5);
		else if(s[1]=='E')show(6);
		else if(s[1]=='Z')show(7);
		else if(s[1]=='Y')show(8);
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 4788 Hard Disk Drive

标签:入门   区域赛   概率   

原文地址:http://blog.csdn.net/david_jett/article/details/46897461

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!