标签:
ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4903 Accepted Submission(s): 2646
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the
profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
Sample Output
Source
其实我觉得题目没说一定只能在一个地方选课复习= =
这题是分组背包。有时候题目中要求只能在一堆物品里面选一个,这样的话就只能给那些物品分组,然后在每一组里面选一个。所以可以对于组别进行一次循环,然后每组里面的物品都进行查找,比较最优者放入背包。
#include<stdio.h>
#include<string.h>
int max(int a,int b)
{
if(a>b)return a;
else return b;
}
int main()
{
int n,m,i,j,k,A[105][105],dp[105];
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)break;
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
scanf("%d",&A[i][j]);
for(i=1;i<=n;i++) //分组
for(j=m;j>=1;j--)
for(k=1;k<=m;k++) //一组里面每个物品都进行决策优化
{
if(j>=k)
dp[j]=max(dp[j],dp[j-k]+A[i][k]);
// printf("%d\n",dp[j]);
}
printf("%d\n",dp[m]);
}
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
hdu 1712 ACboy needs your help(分组背包)
标签:
原文地址:http://blog.csdn.net/aaaaacmer/article/details/46907745