码迷,mamicode.com
首页 > 其他好文 > 详细

POJ

时间:2015-07-16 16:55:41      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8678   Accepted: 4092

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

USACO 2007 February Silver

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
#define maxn 305

string msg;
int d[maxn];// d means d(i~L) that the smallest number of letters should be moved
// so d(0) is the answer.

int main()
{
    int W, L;
    scanf("%d%d", &W, &L);
    string str;
    string *s = new string[W];
    cin>>msg;
    for(int i=0; i<W; i++)
        cin>>s[i];

    d[L] = 0;
    for(int i=L-1; i>=0; i--)
    {
        d[i] = d[i+1] + 1;
        for(int j=0; j<W; j++)
        {
            if(msg[i] == s[j][0])
            {
                int len = s[j].size();
                int t1 = i+1, t2 = 1;
                while(t2 < len && t1 < L)
                {
                    if(msg[t1] == s[j][t2])
                    {
                        t1++, t2++;
                    }
                    else
                    {
                        t1++;
                    }
                }
                if(t2 == len)
                    d[i] = min(d[i], d[t1]+t1-i-t2);
            }
        }
    }
    printf("%d\n", d[0]);
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ

标签:acm   poj   

原文地址:http://blog.csdn.net/dojintian/article/details/46911077

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!