码迷,mamicode.com
首页 > 其他好文 > 详细

uva 753 A Plug for UNIX (最大流)

时间:2015-07-16 22:23:49      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:

uva 753 A Plug for UNIX

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible.

Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can.

Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn’t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug.

In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input
The input will consist of several case. The first line of the input contains the number of cases, and it’s followed bya blank line. The first line of each case contains a single positive integer n ( 1?n?100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m ( 1?m?100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k ( 1?k?100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

There’s a blank line between test cases.

Output
For each case, print a line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in. Print a blank line between cases.

Sample Input

1

4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D

Sample Output

1

题目大意:给出n,有n个插座(可能相同);给出m,表示有m个电器(电器都不相同,但插头会相同),给出电器名以及插头的类型;给出k,表示有k种转接器(转换器每种都有无限个),给出可以桥接的插头和插座。 问说最少有多少个电器没有插座用。

解题思路:我发现最大流的题目难点都在建图上,图建出来了,最大流就好求了。这题的建图步骤如下:1)构建超级源点s与插座相连,容量为该种插座的数量。2)构建超级汇点t,使电器的插头都连向超级汇点,容量为该种插头的数量。3)根据转换器,构建插座与插头之间的边,容量为INF。然后就开始求最大流。最大流不会求的话,看这里

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <queue>
using namespace std;
typedef long long ll;
const int N = 1005;
const int INF = 0x3f3f3f3f;
int n, m, l, t, s;
int a[N], pre[N], rec[N];       
int G[N][N], F[N][N];
char ch[N][N];

int getPos(char* c) {
    for (int i = 0; i < t; i++) {
        if (strcmp(ch[i], c) == 0) return i;
    }
    strcpy(ch[t], c);
    return t++;
}

void input() {
    memset(G, 0, sizeof(G));
    memset(F, 0, sizeof(F));
    memset(ch, 0, sizeof(ch));
    char a[N], b[N];
    scanf("%d\n", &n);  
    for (int i = 0; i < n; i++) { //超级源点与插座相连,容量为该插座的数量
        scanf("%s\n", a);
        G[0][getPos(a)]++;
    }
    scanf("%d\n", &m);
    for (int i = 0; i < m; i++) { //记录下边界点,也就是电器
        scanf("%*s %s\n", a);
        rec[i] = getPos(a);
    }
    scanf("%d\n", &l);
    for (int i = 0; i < l; i++) { //转换器,因为转换器有无限多个,所以容量为INF,并且连接两端
        scanf("%s%s\n", a, b);  
        G[getPos(b)][getPos(a)] = INF;
    }
    for (int i = 0; i < m; i++) {
        G[rec[i]][t]++;
    }
}
int MaxFlow() {
    int ans = 0;
    while (1) {
        memset(a, 0, sizeof(a));
        memset(pre, 0, sizeof(pre));
        queue<int> Q;
        a[s] = INF;
        Q.push(s);
        while (!Q.empty()) {
            int u = Q.front();  Q.pop();
            for (int v = 1; v <= t; v++) {
                if (!a[v] && G[u][v] > F[u][v]) {
                    if (G[u][v] - F[u][v] > a[v]) {
                        pre[v] = u;
                        Q.push(v);  
                        a[v] = min(a[u], G[u][v] - F[u][v]);
                    }
                }
            } 
        }
        if (a[t] == 0) break;
        ans += a[t];
        for (int u = t; u != 0; u = pre[u]) {
            F[pre[u]][u] += a[t];
            F[u][pre[u]] -= a[t];
        }
    }
    return ans;
}
int main() {
    int T;
    scanf("%d", &T);
    while (T--) {
        s = 0;
        t = 1;
        input();            
        printf("%d\n", m - MaxFlow());
        if (T) printf("\n");
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 753 A Plug for UNIX (最大流)

标签:

原文地址:http://blog.csdn.net/llx523113241/article/details/46916213

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!