码迷,mamicode.com
首页 > 其他好文 > 详细

POJ

时间:2015-07-16 22:24:24      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:poj

Language:
Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 14202   Accepted: 4588

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
? 2 <= n <= 1000 
? the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
#define maxn 1005

int d[2][maxn];
double a[maxn];
int n;

int main()
{
    while(~scanf("%d", &n))
    {
        for(int i=0; i<n; i++)
            scanf("%lf", &a[i]);
        for(int i=0; i<n; i++)
        {
            d[0][i] = d[1][i] = 1;
        }

        for(int i=1; i<n; i++)
            for(int j=0; j<i; j++)
            if(a[j] < a[i])
            d[0][i] = max(d[0][i], d[0][j]+1);

        for(int i=n-2; i>=0; i--)
            for(int j=n-1; j>i; j--)
            if(a[j] < a[i])
            d[1][i] = max(d[1][i], d[1][j] + 1);

        int ans = -1;
        for(int i=0; i<n; i++)
            for(int j=i+1; j<n; j++)
            ans = max(ans, d[0][i]+d[1][j]);
        printf("%d\n", n - ans);
    }
    return 0;
}


/*

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

*/


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ

标签:poj

原文地址:http://blog.csdn.net/dojintian/article/details/46916043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!