码迷,mamicode.com
首页 > 其他好文 > 详细

2015华为机试——将字符串中不同字符的个数打印出来

时间:2015-07-17 12:09:18      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:2015华为机试   java   算法   math   hashmap   

描述:
找出字符串中,不同的字符的个数。
 
题目类别: 字符串 
难度: 初级 
运行时间限制: 无限制
内存限制: 无限制
阶段: 入职前练习 
输入:  
输入一个字符串,‘\0‘作为字符串结束符。
 
输出:  
输出字符串中不同字符的个数。
 
样例输入:
122345
                   
样例输出:

5

代码如下:

public class dayin_Char
{
	public static void main(String[] args)
	{
		Scanner sc=new Scanner(System.in);
		while (sc.hasNext())
		{
			String input=sc.nextLine();
			if (input==null)
			{
				return;
			}
			int count=0;
			Map<Integer,Character> hm=new HashMap<Integer, Character>();
			for (int i = 0; i < input.length(); i++)
			{
				if (!hm.containsValue(input.charAt(i)))
				{
					count++;
					hm.put(i, input.charAt(i));
				}
			}
			System.out.println(count);
		}
	}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

2015华为机试——将字符串中不同字符的个数打印出来

标签:2015华为机试   java   算法   math   hashmap   

原文地址:http://blog.csdn.net/zzc8265020/article/details/46923917

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!