码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1513 Palindrome(LCS)

时间:2015-07-17 16:10:49      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3641    Accepted Submission(s): 1252


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
5 Ab3bd
 

Sample Output
2
 

Source
IOI 2000
题目大意:给定一个字符串,要求加最少的字符使得新字符串成为一个回文串。
回文串,就是从头到尾和从尾到头看都是一样的。那么对于一个非回文串s1,我将其倒置成s2。然后求s1与s2的最长公共子序列,对于剩下的不是公共的x个字符,我只要再补上x 个字符就可以组成回文串了。
#include<stdio.h>
#include<string.h>
int maxi(int a,int b)
{
	if(a>b)return a;
	else return b;
}
char str1[5105],str2[5105];
int dp[2][5105];
int main()
{
	int n,i,j,k,l;
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%s",str1);
		for(i=0;i<n;i++)
		str2[i]=str1[n-1-i];
	//	printf("%s\n",str2);
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			int x=i%2;
			int y=1-x;
			if(str1[i-1]==str2[j-1])
			dp[x][j]=dp[y][j-1]+1;
			else 
			{
				dp[x][j]=maxi(dp[y][j],dp[x][j-1]);
			}
		}
		printf("%d\n",n-dp[n%2][n]);
	}
}
这个题目用了滚动数组,如果直接开5000*5000,会爆内存。其实这里只要用到dp[0]和dp[1]就够了,因为是可以循环的。

版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1513 Palindrome(LCS)

标签:

原文地址:http://blog.csdn.net/aaaaacmer/article/details/46927773

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!