码迷,mamicode.com
首页 > 其他好文 > 详细

Beauty of Array

时间:2015-07-17 22:35:40      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

 

#include <iostream>
using namespace std;
const int maxn=100005;
int n[maxn];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        fill(n,n+maxn,0);
        int m;
        cin>>m;
        long long ans=0,dp=0;
        int t;
        for(int i=1;i<=m;i++)
        {
            cin>>t;
            dp=(i-n[t])*t+dp;
            ans+=dp;
            n[t]=i;
        }
        cout<<ans<<endl;
    }
    return 0;
}

  

 

Beauty of Array

标签:

原文地址:http://www.cnblogs.com/demodemo/p/4655693.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!