码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4627(最小公倍数)

时间:2015-07-17 22:38:41      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

                       HDU 4627

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

There are many unsolvable problem in the world.It could be about one or about zero.But this time it is about bigger number. 
Given an integer n(2 <= n <= 10 9).We should find a pair of positive integer a, b so that a + b = n and [a, b] is as large as possible. [a, b] denote the least common multiplier of a, b.
 

Input

The first line contains integer T(1<= T<= 10000),denote the number of the test cases. 
For each test cases,the first line contains an integer n.
 

Output

For each test cases, print the maximum [a,b] in a line.
 

Sample Input

3 2 3 4
 

Sample Output

1 2 3
 
此题的话,因为一个数n由两个正整数a+b得来,所以可以先确定a和b的范围,是从1到n/2 
 因为从n/2+1到n,是和前半部分重复,不用计算 
 然后,就用辗转相除法,算出a和b的最大公约数,a*b/最大公约数=最小公倍数 。
 注意:这种算法易懂,但是很容易超时,自己做的时候就是
 #include <stdio.h>
int main()
{
int a,b,c;
int max,min,t1,t2;
int i,n,T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
max=0;
for(i=1;i<=n/2;i++)
{
a=i;
b=n-i;
a>b?t1=a:t1=b;
t2=n-t1;
while(t2)
{
c=t1%t2;
t1=t2;
t2=c;
}
min=a*b/t1;
if(min>max)
max=min;
}
printf("%d\n",max);
}
return 0;

 

另外还有一种,这是一种奇偶求法,很简单巧妙,经某ACM大神指点得知

#include <stdio.h>

int main()
{
int n,T;
long long max;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
max=0;
if (n==2) printf("1\n");
else
{
if (n%2==0)
{
max=n/2;
if (max%2==0) max=(max+1)*(max-1);
else max=(max+2)*(max-2);
}
else
{
max=n/2;
max=max*(max+1);
}
printf("%I64d\n",max);
}
}
return 0;
}

 

HDU 4627(最小公倍数)

标签:

原文地址:http://www.cnblogs.com/hfc-xx/p/4655734.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!