码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4123 树形DP+RMQ

时间:2015-07-17 22:43:59      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=4123

Problem Description
Bob wants to hold a race to encourage people to do sports. He has got trouble in choosing the route. There are N houses and N - 1 roads in his village. Each road connects two houses, and all houses are connected together. To make the race more interesting, he requires that every participant must start from a different house and run AS FAR AS POSSIBLE without passing a road more than once. The distance difference between the one who runs the longest distance and the one who runs the shortest distance is called “race difference” by Bob. Bob does not want the “race difference”to be more than Q. The houses are numbered from 1 to N. Bob wants that the No. of all starting house must be consecutive. He is now asking you for help. He wants to know the maximum number of starting houses he can choose, by other words, the maximum number of people who can take part in his race.
 

Input
There are several test cases.
The first line of each test case contains two integers N and M. N is the number of houses, M is the number of queries.
The following N-1 lines, each contains three integers, x, y and z, indicating that there is a road of length z connecting house x and house y.
The following M lines are the queries. Each line contains an integer Q, asking that at most how many people can take part in Bob’s race according to the above mentioned rules and under the condition that the“race difference”is no more than Q. 

The input ends with N = 0 and M = 0.

(N<=50000 M<=500 1<=x,y<=N 0<=z<=5000 Q<=10000000)
 

Output
For each test case, you should output the answer in a line for each query.
 

Sample Input
5 5 1 2 3 2 3 4 4 5 3 3 4 2 1 2 3 4 5 0 0
 

Sample Output
1 3 3 3 5
/**
hdu 4123 树形DP+RMQ
题目大意:给定一棵树,每一个点都从当前位置走到距离最远的位置,1~n的连续区间中最大并且走的最远距离差值不超过Q的区间右多大
解题思路:两遍dfs求出在树中到当前点的最长距离:dfs1求出以当前节点为根节点的子树中到该节点的最长距离和次长距离,dfs2将上一步求出的
          最长距离和经过根节点的最长距离比较取最大。利用RMQ查询寻找最大区间
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int N=50050;
int head[N],ip;
struct note
{
    int v,w,next;
}edge[N*2];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

void addedge(int u,int v,int w)
{
    edge[ip].v=v,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}

int maxn[N],smaxn[N],maxid[N],smaxid[N];

void dfs1(int u,int pre)
{
    maxn[u]=smaxn[u]=maxid[u]=smaxid[u]=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(pre==v)continue;
        dfs1(v,u);
        if(maxn[v]+edge[i].w>smaxn[u])
        {
            smaxid[u]=v;
            smaxn[u]=maxn[v]+edge[i].w;
            if(maxn[u]<smaxn[u])
            {
                swap(maxn[u],smaxn[u]);
                swap(maxid[u],smaxid[u]);
            }
        }
    }
}

void dfs2(int u,int pre)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(pre==v)continue;
        if(maxid[u]==v)
        {
            if(smaxn[u]+edge[i].w>smaxn[v])
            {
                smaxn[v]=smaxn[u]+edge[i].w;
                smaxid[v]=u;
                if(maxn[v]<smaxn[v])
                {
                    swap(maxn[v],smaxn[v]);
                    swap(maxid[v],smaxid[v]);
                }
            }
        }
        else
        {
            if(maxn[u]+edge[i].w>smaxn[v])
            {
                smaxn[v]=maxn[u]+edge[i].w;
                smaxid[v]=u;
                if(maxn[v]<smaxn[v])
                {
                    swap(maxn[v],smaxn[v]);
                    swap(maxid[v],smaxid[v]);
                }
            }
        }
        dfs2(v,u);
    }
}

int a[N],n,m;
int dp1[N][30];
int dp2[N][30];

void RMQ_init(int n)
{
    for(int i=1;i<=n;i++)
    {
        dp1[i][0]=a[i];
        dp2[i][0]=a[i];
    }
    for(int j=1;(1<<j)<=n;j++)
    {
        for(int i=1;i+(1<<j)-1<=n;i++)///白书上的模板,次行稍作改动,否则dp数组要扩大一倍防止RE
        {
            dp1[i][j]=max(dp1[i][j-1],dp1[i+(1<<(j-1))][j-1]);
            dp2[i][j]=min(dp2[i][j-1],dp2[i+(1<<(j-1))][j-1]);
        }
    }
}

int rmq(int x,int y)
{
    int k=0;
    while((1<<(k+1))<=y-x+1)k++;
    return max(dp1[x][k],dp1[y-(1<<k)+1][k])-min(dp2[x][k],dp2[y-(1<<k)+1][k]);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        init();
        for(int i=1;i<n;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        dfs1(1,-1);
        dfs2(1,-1);
        for(int i=1;i<=n;i++)
        {
            a[i]=maxn[i];
        }
        RMQ_init(n);
        while(m--)
        {
            int Q;
            scanf("%d",&Q);
            int ans=0;
            int id=1;
            for(int i=1;i<=n;i++)
            {
                while(id<=i&&rmq(id,i)>Q)id++;
                ans=max(ans,i-id+1);
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 4123 树形DP+RMQ

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/46932979

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!