码迷,mamicode.com
首页 > 其他好文 > 详细

HUD 2031: 进制转换

时间:2014-07-08 16:30:28      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   

进制转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23830    Accepted Submission(s): 13344


Problem Description
输入一个十进制数N,将它转换成R进制数输出。
 

Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
 

Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
 

Sample Input
7 2 23 12 -4 3
 

Sample Output
111 1B -11

水题。。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

int main()
{
    int n, m, s, i;
    char c, a[1000];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        i=0;
        if(n<0)
            printf("-");
        while(n)
        {
            s=abs(n%m);
            if(s>=0 && s<=9 || s<0 && s>=-9)
            a[i]='0'+s;
            if(s>9)
            {
                c='A'+s-10;
                a[i]=c;
            }
            n=n/m;
            i++;
        }
        for(int j=i-1; j>=0; j--)
            printf("%c", a[j]);
        printf("\n");
    }
    return 0;
}



HUD 2031: 进制转换,布布扣,bubuko.com

HUD 2031: 进制转换

标签:des   style   blog   http   java   color   

原文地址:http://blog.csdn.net/u013487051/article/details/37535589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!