标签:poj
A Knight‘s Journey
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 29241 |
|
Accepted: 10027 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
这个道题超级坑,要注意字典数。
即
int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
它只能按字典序顺序定义。。
还有就是每一轮输出后要加一个换行。。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int M = 100 + 5;
int chess[M][M];
int h[M];
int l[M];
int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int a, b;
int ok;
void dfs(int x, int y, int ans)
{
h[ans]=x;
l[ans]=y;
if(ans==a*b)
{
ok=1;
return ;
}
for(int i=0; i<8; i++)
{
int tx = x + dx[i];
int ty = y + dy[i];
if(tx>=1 && tx<=b && ty>=1 && ty<=a && chess[tx][ty]==0 && ok==0)
{
chess[tx][ty] = 1;
dfs(tx, ty, ans+1);
chess[tx][ty] = 0;
}
}
}
int main()
{
int n;
scanf("%d", &n);
for(int cas=1; cas<=n; cas++)
{
ok=0;
memset(chess, 0, sizeof(chess));
memset(h, 0, sizeof(h));
memset(l, 0, sizeof(l));
scanf("%d%d", &a, &b);
chess[1][1] = 1;
dfs(1, 1, 1);
printf("Scenario #%d:\n", cas);
if(ok==1)
{
for(int i=1; i<=a*b; i++)
printf("%c%d", h[i]+'A'-1, l[i]);
printf("\n");
}
else
printf("impossible\n");
printf("\n");
}
return 0;
}
POJ 2488:A Knight's Journey,布布扣,bubuko.com
POJ 2488:A Knight's Journey
标签:poj
原文地址:http://blog.csdn.net/u013487051/article/details/37530945