码迷,mamicode.com
首页 > 其他好文 > 详细

poj1979 Red and Black(DFS)

时间:2015-07-19 10:20:56      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:poj1979   poj 1979   red and black   

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 25797   Accepted: 13967

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

[Submit]   [Go Back]   [Status]   [Discuss]


直接附上代码吧。很简单的深搜

#include <stdio.h>
#include <string.h>
char map[25][25];
int dir[4][2]={1,0,-1,0,0,1,0,-1},sum,n,m;
bool limit(int x,int y)//是否出界
{
	if(x>=0&&x<n&&y>=0&&y<m)
	return true;
	else
	return false;
}
void dfs(int x,int y)
{
	map[x][y]='#';//更新地板
	for(int i=0;i<4;i++)
	{
		int xx=x+dir[i][0];
		int yy=y+dir[i][1];
		if(limit(xx,yy)&&map[xx][yy]=='.')
		{
			sum++;
			dfs(xx,yy);
		}
	}
}
int main()
{
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		if(n==0&&m==0)
		break;
		memset(map,0,sizeof(map));
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		sum=0;
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		if(map[i][j]=='@')
		{
			dfs(i,j);
			break;
		}
		printf("%d\n",sum+1);//起点也是,所以+1
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj1979 Red and Black(DFS)

标签:poj1979   poj 1979   red and black   

原文地址:http://blog.csdn.net/su20145104009/article/details/46945355

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!