标签:des style color 使用 os for
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
Sample Output
水题,数位相加到剩下一位就可以了。
不需要使用大数加法。
#include <stdio.h>
#include <string>
#include <iostream>
using std::cin;
using std::string;
int getRootDigit(int num)
{
int root = num;
while (root > 9)
{
root = 0;
while (num)
{
root += num % 10;
num /= 10;
}
num = root;
}
return root;
}
int main()
{
string s;
while (cin>>s)
{
if (s == "0") break;
int num = 0;
for (int i = 0; i < (int)s.size(); i++)
{
num += s[i] - '0';
}
printf("%d\n", getRootDigit(num));
}
return 0;
}
HDU 1013 Digital Roots 题解,布布扣,bubuko.com
HDU 1013 Digital Roots 题解
标签:des style color 使用 os for
原文地址:http://blog.csdn.net/kenden23/article/details/37513447