码迷,mamicode.com
首页 > 其他好文 > 详细

Bestcoders

时间:2015-07-19 12:02:29      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:best   acm   

wyh2000 and pupil

 
 Accepts: 93
 
 Submissions: 925
 Time Limit: 3000/1500 MS (Java/Others)
 
 Memory Limit: 131072/65536 K (Java/Others)
问题描述
青年理论计算机科学家wyh2000在教导他的小学生。
共有n个小学生,编号为1?n。为了增加小学生之间的凝聚力,wyh2000决定将所有小学生分成2组,每组都至少有1个人。
但是有些小学生之间并不认识,而且如果a不认识b,那么b也不认识a。
Wyh2000希望每组中的小学生都互相认识。而且第一组的人要尽可能多。
请你帮wyh2000求出第一组和第二组的人数是多少。如果找不到分组方案,则输出"Poor wyh"。
输入描述
第一行一个数T,表示数据组数。
对于每组数据,第一行两个数n,m,表示小学生数量和互相不认识的小学生的数量。
接下来m行,每行两个数x,y(x<y),表示x不认识yy不认识x。保证一对(x,y)只会出现一次。
T10,0n,m100000
输出描述
对于每组数据,输出答案。
输入样例
2
8 5
3 4
5 6
1 2
5 8
3 5
5 4
2 3
4 5
3 4
2 4
输出样例
5 3
Poor wyh

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
#define maxn 100000+10

int T, n, m, cnt;
int tot, head[maxn], vis[maxn], a[3];
struct Edge
{
    int v, next;
}e[maxn<<1];

void init()
{
    tot = cnt = 0;
    memset(head, -1,  (n+2)*sizeof(int));
    memset(vis, 0, (n+2)*sizeof(int));
}

void add(int u, int v)
{
    e[tot].v = v; e[tot].next = head[u]; head[u] = tot++;
}

bool dfs(int u, int color)
{
    vis[u] = color;
    a[color+1]++;
    for(int i=head[u]; i!=-1; i=e[i].next)
    {
        int v = e[i].v;
        if(vis[v] == color) return false;
        if(!vis[v] && !dfs(v, -color)) return false;
    }
    return true;
}

int main()
{
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        init();
        int u, v;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d", &u, &v);
            add(u, v);
            add(v, u);
        }
        if(n<2)
        {
            printf("Poor wyh\n");
            continue;
        }

        int flag = 0;
        int ans = 0;
        for(int i=1; i<=n; i++)
            if(!vis[i])
        {
            a[0] = a[2] = 0;
            if(!dfs(i, 1))
                {
                    flag = 1;
                    break;
                }
            ans += max(a[0], a[2]);
        }
        if(flag) printf("Poor wyh\n");
        else
        {
            if(ans == n)
                ans -= 1;
            printf("%d %d\n", ans, n-ans);
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Bestcoders

标签:best   acm   

原文地址:http://blog.csdn.net/dojintian/article/details/46952913

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!