码迷,mamicode.com
首页 > 其他好文 > 详细

poj1649 Rescue(BFS+优先队列)

时间:2015-07-19 12:06:08      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:poj1649   poj 1649   

Rescue

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel‘s friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there‘s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel‘s friend.

Process to the end of the file.


Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........


Sample Output

13

广度优先搜索找最短时间。

看代码注释吧

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
	int x,y,time;//x,y方格的位置。time当前所有的时间
	friend bool operator<(node a,node b)//优先队列按照时间大小排序
	{
		return a.time>b.time;
	}
};
priority_queue<node>s;
char map[205][205];//地图
int m,n,vis[205][205],escape,dir[4][2]={0,1,0,-1,1,0,-1,0};//vis标记,dir表示四个方向
bool judge(int x,int y)//判断当前位置时候可以走
{
	if(x>=0&&y>=0&&x<n&&y<m&&!vis[x][y]&&map[x][y]!='#')
	return true;
	else
	return false;
}
int tonum(int x,int y)//把相应的道路,警卫换算成时间
{
	if(map[x][y]=='x')
	return 2;
	else
	return 1;
}
void bfs(int x,int y)//广度优先搜索
{
	node temp,temp1;
	temp.time=0,temp.x=x,temp.y=y;
	vis[x][y]=1;
	s.push(temp);//把temp入队列
	while(!s.empty())
	{
		temp=s.top(),s.pop();
		temp1=temp;
		if(map[temp.x][temp.y]=='a')//提前结束循环,因为用的优先队列,所以当前找到的肯定是最小的
		{
			escape=temp.time;
			break;
		}
		for(int i=0;i<4;i++)
		{
			int xx=temp.x+dir[i][0];
			int yy=temp.y+dir[i][1];
			if(judge(xx,yy))
			{
				vis[xx][yy]=1;//当前位置已浏览 标记为1
				temp.x=xx,temp.y=yy,temp.time=temp.time+tonum(xx,yy);
				s.push(temp);//更新队列
			}
			temp=temp1;//由于才判断了一个方向,所以还需要temp1保持上次的位置
		}
	}
}
int main()
{
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		escape=0;
		memset(vis,0,sizeof(vis));
		memset(map,0,sizeof(map));
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		if(map[i][j]=='r')
		{
			bfs(i,j);
			break;
		}
		if(escape)
		printf("%d\n",escape);
		else
		printf("Poor ANGEL has to stay in the prison all his life.\n");
		while(!s.empty())//一定要记得清队列。。刚刚wa了一次
		s.pop();
	}
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj1649 Rescue(BFS+优先队列)

标签:poj1649   poj 1649   

原文地址:http://blog.csdn.net/su20145104009/article/details/46952511

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!