码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1149 PIGS(最大流)

时间:2015-07-19 21:52:47      阅读:88      评论:0      收藏:0      [点我收藏+]

标签:poj   最大流   

题目链接:http://poj.org/problem?id=1149


Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can‘t unlock any pighouse because he doesn‘t have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7

Source



技术分享
【题目大意】 (转:http://wenku.baidu.com/view/0ad00abec77da26925c5b01c.html
有M个猪圈,每个猪圈里初始时有若干头猪。一开始所有猪圈都是关闭的。依次来了N个顾客,每个顾客分别会打开指定的几个猪圈,从中买若干头猪。每个顾客分别都有他能够买的数量的上限。每个顾客走后,他打开的那些猪圈中的猪,都可以被任意地调换到其它开着的猪圈里,然后所有猪圈重新关上。问总共最多能卖出多少头猪。(1 <= N <= 100, 1 <= M <= 1000)  
举个例子来说。有3个猪圈,初始时分别有3、1和10头猪。依次来了3个顾客,第一个打开1号和2号猪圈,最多买2头;第二个打开1号和3号猪圈,最多买3头;第三个打开2号猪圈,最多买6头。那么,最好的可能性之一就是第一个顾客从1号圈买2头,然后把1号圈剩下的1头放到2号圈;第二个顾客从3号圈买3头;第三个顾客从2号圈买2头。总共卖出2+3+2=7头。 
 
【建模方法】 
不难想象,这个问题的网络模型可以很直观地构造出来。就拿上面的例子来说,可以构造出图1所示的模型(图中凡是没有标数字的边,容量都是∞): 
? 三个顾客,就有三轮交易,每一轮分别都有3个猪圈和1个顾客的结点。 ? 从源点到第一轮的各个猪圈各有一条边,容量就是各个猪圈里的猪的初始数量。 
? 从各个顾客到汇点各有一条边,容量就是各个顾客能买的数量上限。 ? 在某一轮中,从该顾客打开的所有猪圈都有一条边连向该顾客,容量都是∞。 
? 最后一轮除外,从每一轮的i号猪圈都有一条边连向下一轮的i号猪圈,容量都是∞,表示这一轮剩下的猪可以留到下一轮。 
? 最后一轮除外,从每一轮被打开的所有猪圈,到下一轮的同样这些猪圈,两两之间都要连一条边,表示它们之间可以任意流通

代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f

#define MAXN 500047
#define MAXM 1247

int head[MAXM], pre[MAXM];
int dep[MAXM], cur[MAXM], gap[MAXM];
int EN;
int con[MAXM][MAXM];//记录商人与猪栏之间是否相连
struct Edge
{
    int to,next,cap,flow;
} edge[MAXN]; //注意是MAXM
int tol;
int k, c, m;
int s, e;//源点,汇点
int map[MAXM][MAXM];
//加边,单向图三个参数,双向图四个参数
void addedge(int u,int v,int w,int rw = 0)
{
    edge[tol].to = v;
    edge[tol].cap = w;
    edge[tol].flow = 0;
    edge[tol].next = head[u];
    head[u] = tol++;
    edge[tol].to = u;
    edge[tol].cap = rw;
    edge[tol].flow = 0;
    edge[tol].next = head[v];
    head[v] = tol++;
}
int Q[MAXN];

void BFS(int start,int end)
{
    memset(dep,-1,sizeof(dep));
    memset(gap,0,sizeof(gap));
    gap[0] = 1;
    int front = 0, rear = 0;
    dep[end] = 0;
    Q[rear++] = end;
    while(front != rear)
    {
        int u = Q[front++];
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].to;
            if(dep[v] != -1)continue;
            Q[rear++] = v;
            dep[v] = dep[u] + 1;
            gap[dep[v]]++;
        }
    }
}
int S[MAXN];
//输入参数:起点、终点、点的总数
//点的编号没有影响,只要输入点的总数
int sap(int start,int end,int N)
{
    BFS(start,end);
    memcpy(cur,head,sizeof(head));
    int top = 0;
    int u = start;
    int ans = 0;
    while(dep[start] < N)
    {
        if(u == end)
        {
            int Min = INF;
            int inser;
            for(int i = 0; i < top; i++)
                if(Min > edge[S[i]].cap - edge[S[i]].flow)
                {
                    Min = edge[S[i]].cap - edge[S[i]].flow;
                    inser = i;
                }
            for(int i = 0; i < top; i++)
            {
                edge[S[i]].flow += Min;
                edge[S[i]^1].flow -= Min;
            }
            ans += Min;
            top = inser;
            u = edge[S[top]^1].to;
            continue;
        }
        bool flag = false;
        int v;
        for(int i = cur[u]; i != -1; i = edge[i].next)
        {
            v = edge[i].to;
            if(edge[i].cap - edge[i].flow && dep[v]+1 == dep[u])
            {
                flag = true;
                cur[u] = i;
                break;
            }
        }
        if(flag)
        {
            S[top++] = cur[u];
            u = v;
            continue;
        }
        int Min = N;
        for(int i = head[u]; i != -1; i = edge[i].next)
            if(edge[i].cap - edge[i].flow && dep[edge[i].to] < Min)
            {
                Min = dep[edge[i].to];
                cur[u] = i;
            }
        gap[dep[u]]--;
        if(!gap[dep[u]])return ans;
        dep[u] = Min + 1;
        gap[dep[u]]++;
        if(u != start)u = edge[S[--top]^1].to;
    }
    return ans;
}


void init()
{
    memset(head,-1,sizeof(head));
    memset(con,0,sizeof(con));
    EN = 0;
}

int main()
{
    int m, n;
    while(~scanf("%d%d",&m,&n))
    {
        init();
        int num;
        for(int i = 1; i <= m; i++)
        {
            scanf("%d",&num);
            addedge(0, i, num);//源点
        }
        int a, b, c[MAXM];
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&a);
            for(int j = 1; j <= a; j++)
            {
                scanf("%d",&c[j]);
                addedge(c[j], m+i, INF);//猪和商人
                con[i][c[j]] = 1;//第i个商人能买的
            }
            scanf("%d",&b);//能买几头
            addedge(m+i, m+n+1, b);//商人和汇点
        }

        for(int i = 1; i < n; i++)//商人与商人之间,从前到后
        {
            int vis[MAXM];//记录是否已经加过边
            memset(vis,0,sizeof(vis));
            for(int j = 1; j <= m; j++)
            {
                if (con[i][j])//如果商人能买
                {
                    for(int k = i+1; k <= n; k++)
                    {
                        if (con[k][j] && !vis[k])//判断商人k和猪栏j是否相连
                        {
                            addedge(m+i, m+k, INF);
                            vis[k] = 1;
                        }
                    }
                }
            }
        }
        int sta = 0;//起点
        int end = m+n+1;//汇点
        int N = m+n+2;//总结点数
        int ans = sap(sta,end,N);

        printf("%d\n",ans);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1149 PIGS(最大流)

标签:poj   最大流   

原文地址:http://blog.csdn.net/u012860063/article/details/46957175

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!