码迷,mamicode.com
首页 > 其他好文 > 详细

Compound Words

时间:2015-07-19 23:09:44      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is theconcatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line,in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, inalphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

 

Sample Output

alien
newborn


AC代码:
#include"iostream"
#include"set"
using namespace std;
int main()
{
    set<string> dic;
    string s;
    while(cin>>s) dic.insert(s);
    set<string> ::iterator it;
    for(it=dic.begin();it!=dic.end();it++)
    {
     string str,sub1,sub2;
     str=*it;
     for(int i=0;i<str.size()-1;i++)
     {
         sub1=str.substr(0,i+1);
         sub2=str.substr(i+1,str.size()-i-1);
         if(dic.find(sub1)!=dic.end()&&dic.find(sub2)!=dic.end())
         {
            cout<<str<<endl;
            break;     //一定要即时break掉,以免重复
         }
     }


    }
    return 0;
}

Compound Words

标签:

原文地址:http://www.cnblogs.com/zsyacm666666/p/4659949.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!