码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1071 The area

时间:2015-07-20 10:57:21      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8587    Accepted Submission(s): 6013


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

技术分享

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.

纯数学几何计算题,数学渣,参考大神的解析  设直线方程:y=kx+t…………………………………………………………(1)   抛物线方程:y=ax^2+bx+c……………………………………………………(2) 已知抛物线顶点p1(x1,y1),两线交点p2(x2,y2)和p3(x3,y3) 斜率k=(y3-y2)/(x3-x2)……………………………………………………(3) 把p3点代入(1)式结合(3)式可得:t=y3-(k*x3) 又因为p1是抛物线的顶点,可得关系:x1=-b/2a即b=-2a*x1………………(4) 把p1点代入(2)式结合(4)式可得:a*x1*x1-2a*x1*x1+c=y1化简得c=y1+a*x1*x1……(5) 把p2点代入(2)式结合(4)式和(5)式可得:a=(y2-y1)/((x1-x2)*(x1-x2)) 于是通过3点求出了k,t,a,b,c即两个方程式已求出 题目时求面积s 通过积分可知:s=f(x2->x3)(积分符号)(ax^2+bx+c-(kx+t))                =f(x2->x3)(积分符号)(ax^2+(b-k)x+c-t)                =[a/3*x^3+(b-k)/2*x^2+(c-t)x](x2->x3)                =a/3*x3*x3*x3+(b-k)/2*x3*x3+(c-t)*x3-(a/3*x2*x2*x2+(b-k)/2*x2*x2+(c-t)*x2) 化简得: 面积公式:s=-(y2-y1)/((x2-x1)*(x2-x1))*((x3-x2)*(x3-x2)*(x3-x2))/6; 2015,7,20 

#include<stdio.h>
int main(){
	int t;
	double x1,x2,x3,y1,y2,y3,s;
	scanf("%d",&t);
	while(t--){
		scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
		s=(y2-y1)/((x2-x1)*(x2-x1))*((x3-x2)*(x3-x2)*(x3-x2))/6;
		printf("%.2lf\n",-s);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu 1071 The area

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/46964235

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!